Menu

Search



Prism Suite System Requirements and Supported Platforms

New Boundary Support
Install/Upgrade - General Information

The information in this article applies to Prism Suite®, Prism Deploy®, Prism Asset Manager®, Prism Deploy Packager, Prism Portal™, and Prism Mobile™

Current Release:
18.0
Prim Console (software
deployment, asset
management)*
Prism Deploy Packager** New Boundary Channel
Server
New Boundary Client** Prism Portal and Prism
Mobile web application
Operating System, 32
& 64 bit
Windows 10 Windows 10 Windows Server 2019 Windows 10 Windows Server 2019
Windows 8, 8.1 Windows 8, 8.1
Windows Server 2016 Windows 8, 8.1 Windows Server 2016
Windows Server 2016 Windows Server 2019 Windows Server 2012 R2 Windows Server 2019 Windows Server 2012 R2
Windows Server 2012 R2 Windows Server 2016
Windows Server 2016
Window Server 2012 R2 Windows Server 2012 R2
Database, 32 & 64 bit MS SQL Server 2019 MS SQL Server 2019
MS SQL Server 2017 MS SQL Server 2017
MS SQL Server 2016 MS SQL Server 2016
MS SQL Server 2014 MS SQL Server 2014
MS SQL Server 2012 MS SQL Server 2012
Other Components .Net Framework 4.0 .Net Framwork 4.0 .net Framerwork 4.5.1
IIS 7, 7.5,8,8.5,10 with
ASP.NET enabled
PowerShell 2,3,4,5,6
Processor Pentium or higher Pentium or higher
Intel Core Duo or higher Pentium or higher
Intel Core Duo or higher
Ram 2 GB 512 MB 2 GB 512 MB 2 GB

Disk space for
installed
Components

100MB 40MB 65MB 12MB Web app: 15BM
(Mobile)37MB(Portal
Database: 4GB ; Database: 40 MB
(Mobile) 60 MB (Portal)

Microsoft Supplemental Installations

Other installations that may be needed include: SQL Server, MDAC 2.8, .Net Framework

These third-party items will be included in the standard installations as noted for the individual components above.

* DEVEXPRESS and INFRAGISTICS DLLs are required to support reporting functions.

** CAPICOM.DLL is required to support Package authentication.

*** Microsoft IIS 7, 7.5, 8, 8.5, or 10 must be installed on a Web server if you intend to use the NBTProxy Service to enable HTTP/HTTPS communication from the Prism Console or New Boundary client outside the network perimeter, to a New Boundary Channel Server inside the network perimeter. IIS installation and configuration is not part of the Prism Suite installation. Note: If you choose to install IIS 7, you must also install the IIS 6.0 management tools in order to install the NBTProxy Service. (Installing the IIS 6 management tools is a choice during installation of IIS 7.)

**** The following Microsoft components are prerequisites to installing SQL Server 2008 R2 Express. They will NOT be downloaded during installation. If you plan to install SQL 2008 R2 Express as part of the Prism Suite installation (instead of using an existing SQL server), please install the prerequisites before starting the installation.


Also In This Category


On a scale of 1-5, please rate the helpfulness of this article


Not Helpful
Very Helpful
Optionally provide your comments to help us improve this article...

Thank you for your feedback!

Add Your Comments
Name:
Email Address:
RadEditor - HTML WYSIWYG Editor. MS Word-like content editing experience thanks to a rich set of formatting tools, dropdowns, dialogs, system modules and built-in spell-check.
RadEditor's components - toolbar, content area, modes and modules
   
Toolbar's wrapper  
Content area wrapper
RadEditor's bottom area: Design, Html and Preview modes, Statistics module and resize handle.
It contains RadEditor's Modes/views (HTML, Design and Preview), Statistics and Resizer
Editor Mode buttonsStatistics moduleEditor resizer
 
 
RadEditor's Modules - special tools used to provide extra information such as Tag Inspector, Real Time HTML Viewer, Tag Properties and other.
   
Verification Code:
Details
Last Modified: 2 Months Ago
Last Modified By: New Boundary Support
Type: INFO
Article not rated yet.
Article has been viewed 118 times.
Options
Customer Support Software By InstantKB 2015-2
Execution: 0.000. 12 queries. Compression Disabled.